Ask your WordPress questions! Pay money and get answers fast! (more info)

the button WordPress

  • SOLVED

Hi,
pure-mineral.com

The button "add media" does not work even with the default theme Twenty Eleven, not with the chosen theme.
Any idea why??

i have the current wordpress installation in the site. version 3.5.
I have also disabled all plugins and nothing.
I have also changed the theme to the basic one and nothing.

ALso, not working on chrome, firefox and explorer.

Thanks in advance,
Sharon

Answers (8)

2012-12-27

Dbranes answers:

Hi, just one idea from:

http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list

<blockquote>On some hosting environments, aggressive settings for the "mod_pagespeed" addon can break the javascript code and cause scripts to not be able to function. This can cause many problems, such as widgets not working, menus not being draggable, the customizer not working, or the media screens not being available.

To fix the issue, you will need to disable mod_pagespeed, or adjust its settings to not take effect in the wp-admin directories. You may need to ask your hosting service for help on how to do this.
</blockquote>

your site seems to be using it, i.e.

X-Mod-Pagespeed 1.1.23.1-2169


so this might or might not be a problem ;-)

<strong>ps:
</strong>

this link will help you diagnose any javscript errors:

[[LINK href="http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors"]]http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors[[/LINK]]


Dbranes comments:

you could try to place this code:

<IfModule pagespeed_module>
ModPagespeed off
</IfModule>


at the top of an .htaccess file in the directory where you want to disable the modpagespeed module.


cloudnclear comments:

Thank you!!! It's working :-)

2012-12-27

S├ębastien | French WordpressDesigner answers:

probably a problem with a function in functions.php of your choosen theme


cloudnclear comments:

i'm not sure as this problem occures also on the basic wordpress theme.

2012-12-27

Arnav Joy answers:

which wp version are you using?


cloudnclear comments:

The latest. New site.


Arnav Joy comments:

if you have installed some plugins then try deactivating them .

take backup of your site first before doing it.

also test it in different browsers.


cloudnclear comments:

did all.
nothing is changing.

2012-12-27

John Cotton answers:

Have a look in a javascript debugger and see if you are getting a js error - that's a common reason for that button not working.

2012-12-27

phppoet answers:

Is it not working for admin or for all role like subscribers , contributors etc. Wordpress by default will show add media button to users with user role with upload_files attributes .

use this plugin
http://wordpress.org/extend/plugins/capsman/
if you want to add upload_files attribute to contributor or author .

2012-12-27

Ellah Alzona answers:

Try to switch back to the default theme like "twenty eleven" then try "add media" if it does work then it means its not the plugins fault but its your theme has a problem.

From there check your theme files.


Ellah Alzona comments:

Try then updating your wordpress version.
Empty your cache, refresh fully with keyboard combination CTRL + F5 and try with diffrent browsers.

Hope it helps.


Ellah Alzona comments:

Try using another computer :) and check it out.


cloudnclear comments:

also happens on different computers!


Ellah Alzona comments:

Must be problem with your hosting.
Send me the login info's and see if i can help.

2012-12-27

Kevan Judah answers:

Sounds like the core WP files might be broken. Perhaps during the latest upgrade?
Under "Upgrade" in the dashboard, try the "Re-install Now" button.

This will re-install WP, not your theme, not your content, and perhaps fix the problem.

2012-12-27

Asad Iqbal answers:

How did you install your wordpress? Using auto installer from hosting panel or manually by uploading files?