Ask your WordPress questions! Pay money and get answers fast! (more info)

Your server is running PHP ...but WordPress 3.2.1 requires.. WordPress

  • SOLVED

Hi,

i'm trying to move a wordpress website from my server to another server.
But when i uploaded all the files with cyberduck, i got this message
"Your server is running PHP version 4.4.4-8+etch6 but WordPress 3.2.1 requires at least 5.2.4"

What should i do?

thanks
Greetings
Karina

Answers (10)

2011-11-10

Luis Cordova answers:

yes forget you need proper hosting


Luis Cordova comments:

this hosting is very cheap, I have been and recommended them, I am an affiliate http://bit.ly/9TTSvJ so i fully endorse it, transfer and cpanel are so easy and standard, they are now the only sharedhosting if not the best and more free to do any sort of processing than any other i have seen. I am running symfony2 apps on it which require php5.3 the latest php


Luis Cordova comments:

[[LINK href="http://bit.ly/9TTSvJ"]]http://bit.ly/9TTSvJ[[/LINK]]


Luis Cordova comments:

private message me if you need me to move your site, i would help


Luis Cordova comments:

If i upload an older version of wordpress, would everything work then?

don't use old versions is inviting attacks you want to be sure you provide the right thing

i will deploy it for you, just talk with changing the hosting with your client


Luis Cordova comments:

do not recommend hostgator because it is safer but restrictive, the one i said is the best balance and you will be running php5.3 for cheapest in the world, I am so happy about my hosting


Luis Cordova comments:

the client has to provide you with hosting and registrar information to forward the DNSs to make the switch, then hosting for you will be $3.5-$7 a month


Luis Cordova comments:

notice upgrading php is not something you can do, really this is handled by admins, especially when we are talking about php5.3, it is not for regular people like us, security is important!

so get proper hosting, if your old hosting tries to upgrade, their admins will tell you all sort of things and make you wait for months before that happens!

switch, put that condition to your client or face a hard time ahead


Karina Soors comments:

Hi,

thanks for this information, i will ask my client if we can change hosting.
But meanwhile, can i do this:
if people visit the site www.filenbaukis.be they get redirected to www.studiowootwoot.com/filenbaukis2 ?


Luis Cordova comments:

if you have access to registrar then yes you can do a DNS redirect change to point to that subdomain or directory, that is standard, i can help you with that but you need access nonetheless

2011-11-10

Milan Petrovic answers:

You must upgrade PHP on your server, or change hosting company. PHP4 is long time outdated and no longer supported. WP from 3.2 requires PHP 5.2.4.

Some hosting companies offer both PHP4 and PHP5 in the same time, so you must check with them about switching to new PHP, and check if PHP5 they have is at least 5.2.4.

Milan

2011-11-10

Jurre Hanema answers:

Install a newer version of PHP or ask your hosting company to do so.

If they don't want to do that, search a new hoster immediately. PHP 4 is like waaaay outdated.

2011-11-10

Luis Abarca answers:

Get a hosting plan on Dremahost or HostGator, is cheap and WP works very well, you can even run Symfony with PHP 5.3.

By the way, you can't upgrade your PHP if you have a normal hosting plan, you need a VPS with root access to do that, and if your server have outdated software your best bet is to change your current hosting provider right now. It can represent a security risk to your site.

2011-11-10

Ehthisham tk answers:

before asking support make sure you are selected the correct php version.some server supports multiple php bersions.
If that didnt worked then ask them to upgrade their php if they are not able to then moving to another hosting company is the only way i recommend hostmonster

2011-11-10

Nile Flores answers:

You will need to have the web host of the server upgrade the PHP to PHP5. Installing a previous version of WordPress or PHP is a security issue, so definitely get that host to upgrade your server.

I see other people are recommending different web hosts. If you are fine where you are, just ask your web host to update their servers. They should do it happily and for free because they want to make sure their business is secure and they have integrity too. And once you request the update, it normally takes within an hour to get it done, but that also depends on how fast your web hosts support gets to each ticket submission. It is not a difficult upgrade... at least it should not be for your web host.

Remember, to keep your scripts (PHP, CGI, or any markup) up to date as your web host will hold you responsible in the case that your site is hacked and becomes a security issue for the whole server. This is not to scare you, but many web hosts do have this in their user policies and also, Matt Mullenweg himself always suggests to keep your WordPress up-to-date to be the most secure.

2011-11-10

Drew Clardy answers:

I am willing to bet that both versions are installed on your box, but it defaults to Php4. You just need to tell it to use php5.

Try this in your .htaccess:

AddHandler x-httpd-php5 .php .php5
AddHandler x-httpd-php .php4


Karina Soors comments:

Hi, thanks!
Could u tell me where i can find this .htaccess file?
greetings
Karina


Drew Clardy comments:

The .htaccess file should be in the root of your web folder. If not, you can create it. Just add those lines and save it as .htaccess.


Karina Soors comments:

Thanks,
i've saved it and now i get this
"Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Apache/2.2.3 (Debian) Server at file-hostingst509.isp.belgacom.be Port 80"


Drew Clardy comments:

Who is your hosting provider? I only ask because you are using a Debian webserver. That means no cPanel, but maybe DirectAdmin as the control panel? Can you PM that info to me?


Drew Clardy comments:

After reading some about your hosting provider, you can remove the other lines that I told you from .htaccess. They do it another way.

Add a file with this name in the root of your web folder,

bgc_force_php5


It should not have anything other than that.

2011-11-10

Jim Dugan answers:

Contact your hosting company. If they can't/won't change it, find other hosting. PHP5 should be included and is at any decent hosting company.

Sooner or later, you'll need something in a WP upgrade, so might as well make the switch now.

edit: and since you've already uploaded, is the site now down? If so, do you have an old set of the WP files that you can upload in their place? Or since you're moving maybe it's all still at the old host?


Karina Soors comments:

Hi,

i'm updating a site for someone else.. i just got the ftp information, but nothing from which server they are on...
If i upload an older version of wordpress, would everything work then?

thanks!
greetings
Karina


Jim Dugan comments:

If you upload old WordPress files, it would PROBABLY work but it's only a matter of time (experience tells me) before there's a version of WordPress that has important security upgrades and is highly recommended.

You NEED php5+

You can find what the hosting company is from a whois search. Try http://betterwhois.com to find out where it's hosted. Often the FTP info will also get you into the hosting company's control panel, where you can find out about upgrading PHP.

2011-11-10

Maor Barazany answers:

You should change hosting company...Or ask their support to upgrade to php5, which is minimum requirements for WP3.2+

2011-11-10

dr_killpatient answers:

Hi Karina.

You should to upgrade your php version at least to 5.2.4 version.

Regards


Karina Soors comments:

hi, thanks for all the answers,
but how can i upgrade my php version?
Can i do this myself?

thanks!


dr_killpatient comments:

Yes, If you got VPS/VDS/dedicated server with root access.