Ask your WordPress questions! Pay money and get answers fast! (more info)

What does phpMyAdmin 4.0 want for config? WordPress

  • SOLVED

I have not used phpMyAdmin for many years. I am now setting it up for a client. The config seems strange to me. Am I correct in saying it wants me to set up 2 databases, 1 for itself and 1 for the real database that the client wants to look at?

Can anyone post a working example of a real config from the newest 4.0 version of phpMyAdmin?

Answers (6)

2013-05-07

Daniel Yoen answers:

hello,

you can use quick setup by open : /setup

<?php

$i = 0;

$i++;

$cfg['Servers'][$i]['verbose'] = '';
$cfg['Servers'][$i]['host'] = '127.0.0.1';
$cfg['Servers'][$i]['port'] = '';
$cfg['Servers'][$i]['socket'] = '';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '123';

$cfg['blowfish_secret'] = 'a8ba8b9c6d7ca8b6c6d6d';
$cfg['DefaultLang'] = 'en-utf-8';
$cfg['ServerDefault'] = 1;
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';
?>


hope this help :-)


Lawrence Krubner comments:

If I go to /setup I get:

Cannot load or save configuration
Please create web server writable folder config in phpMyAdmin top level directory as described in documentation. Otherwise you will be only able to download or display it.


but I have created the directory


Lawrence Krubner comments:

I see this:

[[LINK href="http://docs.phpmyadmin.net/en/latest/setup.html#quick-install"]]http://docs.phpmyadmin.net/en/latest/setup.html#quick-install[[/LINK]]


but even if I try to fill in that info manually, phpmyadmin complains about a "pma" user not existing. I think it wants this for itself?


Daniel Yoen comments:

try this :

cd phpmyadmin
# mkdir config
# chmod o+rw config
# cp config.sample.inc.php config/config.inc.php
# chmod o+w config/config.inc.php


Lawrence Krubner comments:

See screenshot. I am now getting 503 Bad Gateway on every request. But if I use the Terminal and log into MySql from the command line, everything works fine.