Ask your WordPress questions! Pay money and get answers fast! Comodo Trusted Site Seal
Official PayPal Seal

WP jQuery backend conflicts(Buddypress) WordPress

Hello,

I have upgraded to WP 3.2.1 and Buddypress 1.2.9 everything seemed to be working fine until I tried to do somethings in the backend. Such as insert image into post, edit image from library, and edit widgets. I receive this when I use firebug:

Uncaught TypeError: Object #<Object> has no method 'swing' in jQuery.js:18

If I disable Buddypress the problem goes away.

I hope this is a enough information, if not let me know.


Thanks,
Adam

Answers (3)

2011-08-30

Reland Pigte answers:

Try to update your easing jquery plugin here : http://gsgd.co.uk/sandbox/jquery/easing/

Hope that helps..


adam b comments:

Thank you for the reply, I am kind of confused of where I should put the .js file at?


Reland Pigte comments:

can I have the link of your site so I could investigate? or you can just PM me the link if you don't want it to publish here.

Cheers,

2011-08-30

Jurre Hanema answers:

This might be related to BuddyPress bugs #1940 and #2648, which I just found on Google.

So that is why you might want to try this: download this file: http://buddypress.trac.wordpress.org/export/3498/trunk/bp-themes/bp-default/_inc/global.js

And save it to <your buddypress folder>/bp-themes/bp-default/_inc/global.js, overwriting the old global.js.


adam b comments:

Hmm, still receiving the errors. Although, it seems like more people are having this issue than I thought.

2011-08-30

ej_emman answers:

Error: Uncaught TypeError: Object #<Object> has no method 'swing' in jQuery.js:18

I think it was clearly stated that there was no method 'swing' found on the object in Jquery.js line 18..
That why when buddypress uses method swing that will be fetches to jquery.js, this error will occur.


I think you try to update your jquery.js

found in /yourwebsite/wp-includes/js/jquery/jquery.js

use this updated version: [[LINK href="http://pastebin.com/fr5zdkuH"]]http://pastebin.com/fr5zdkuH[[/LINK]]

hope this helps..




adam b comments:

Hi Ej,

I updated my jquery.js with the provided pastebin link and still receiving the errors, but now it says in loads-scripts.php