Ask your WordPress questions! Pay money and get answers fast! Comodo Trusted Site Seal
Official PayPal Seal

WP Content Slideshow IE8 Fix WordPress

  • SOLVED

Hi, I have just built a site using wordpress and the wp content slideshow (http://wordpress.org/extend/plugins/wp-content-slideshow/)

http://www.vivasound.com.au/

It works great in all browsers except IE8, in IE8 the first slide shows, but when you click on the second it shows a blank screen and on the 3rd button on menu it shows the wrong image.

Can someone help me with this fix?

Some things I have been reading, might not be related to same plugin, but IE8 jQuery fixes:

- http://erikvandeven.com/jquery/how-to-use-wp-cycle/
- http://forum.jquery.com/topic/jquery-cycle-all-2-72-js-returns-cycleh-and-cyclew-as-0-in-ie8-when-used-postition-absolute
-

Answers (3)

2011-07-27

Romel Apuya answers:

perhaps you try validating your site..

and omit possible errors. [[LINK href="http://validator.w3.org/check?uri=http%3A%2F%2Fwww.vivasound.com.au%2F&charset=%28detect+automatically%29&doctype=Inline&group=0"]]here[[/LINK]]

2011-07-28

Hai Bui answers:

There is something wrong with your plugin, did you modify it?

When I check the source code of the slideshow content (the slides), there are weird close tags <strong></a></strong> at the end of each slide (<li></li>) I believe this is the reason why the slideshow has problem in IE.


<div class="content_slideshow">
<ul>
<li id="main-post-1" title="Detective Dee">
<a rel="shadowbox;width=512;height=288;" href="http://vimeo.com/moogaloop.swf?clip_id=24592497&server=vimeo.com&show_title=0&amp;byline=0&amp;portrait=0&amp;color=000&amp;autoplay=1">
<img src="http://www.vivasound.com.au/wp-content/uploads/2011/06/DD1.jpg" /></a>
</li>
</a>
<li id="main-post-2" title="IpMan">
<a rel="shadowbox;width=512;height=288;" href="http://vimeo.com/moogaloop.swf?clip_id=24500413&server=vimeo.com&show_title=0&amp;byline=0&amp;portrait=0&amp;color=000&amp;autoplay=1"><img src="http://www.vivasound.com.au/wp-content/uploads/2011/06/IPman1.jpg" /></a>
</li>
</a>

...........
</ul>
</div>

2011-07-27

Kristin Falkner answers:

Something to try... I believe that IE8 has trouble with the fade jQuery cycle plug-in transition. Can you test by changing fx: 'fade' to fx: 'scrollDown' or any other transition option listed at [[LINK href="http://jquery.malsup.com/cycle/begin.html"]]the jQuery cycle website[[/LINK]]

This should be changed in this file:
http://www.vivasound.com.au/wp-content/plugins/wp-content-slideshow/scripts/slideshow.js?ver=1.3

Line 7