Ask your WordPress questions! Pay money and get answers fast! Comodo Trusted Site Seal
Official PayPal Seal

PHP version 5.1.6 but WordPress 3.4.2 requires at least 5.2.4 WordPress


I installed the new version of WordPress and got this error:

<blockquote>Your server is running PHP version 5.1.6 but WordPress 3.4.2 requires at least 5.2.4. </blockquote>

For various reason, I can not upgrade PHP on this server. Does anyone know which version of WordPress I need? And where is it?

Answers (4)


Michael Caputo answers:

The release archive is here:

Not sure about the PHP requirements though. I would go back to 3.1 maybe?


Navjot Singh answers:

Get Wordpress 3.1.4 in that case from [[LINK href=""]]Archives[[/LINK]] because the requirements changed from 3.2.


Gabriel Merovingi answers:


3.1 requires PHP 4.3. You could start there. For more info


Manoj Raj answers:

I think you should ask support from hosting guys...May be some upgrades will be going on in your web host... Or change the web host.. Or Install older version of WordPress....

Lawrence Krubner comments:

We own the servers. We have 4 servers at a co-lo with Verio and 5 other servers at Servers4You. We can do anything we want with these machines, but we are in lock down right now because we are about to push out some code and we need to keep everything as stable as possible. We do not want any last minute surprises. The dev machine and the production machine need to be identical. We can not upgrade right now.