Ask your WordPress questions! Pay money and get answers fast! Comodo Trusted Site Seal
Official PayPal Seal

HTTP error when uploading media WordPress

  • SOLVED

I'm trying to upload a picture in Wordpress post.

I get HTTP error (red).

Tried everything suggested from the WP forums (very awful) for e.g.

adding some code to htaccess
changing permission

Didn't work.

Someone suggested mod_security might interfere with the upload process (something to do with flash uploader useragent being blacklisted) so I tried HTTP upload

Didn't work.

I have the Wordpress installed on a VPS so I have root access.

If only someone can solve this mystery..

Answers (4)

2012-05-26

Agus Setiawan answers:

hi, let me help you to fix this, please send me an access to your ftp / wp dashboard,

thanks.

or add this line to your .htaccess file

<blockquote><IfModule*mod_security.c>
<Files async-upload.php>
SecFilterEngine Off
SecFilterScanPOST Off
</Files>
</IfModule>
<IfModule mod_security.c>
<Files async-upload.php>
SecFilterEngine Off
SecFilterScanPOST Off
</Files>
</IfModule></blockquote>


Agus Setiawan comments:

or try to use no flash uploader plugin for a while, http://trac.wordpress.org/attachment/ticket/6406/no-flash-uploader.php?format=raw


ianbong comments:

I added the codes, with the result of my site being inaccessible and displaying 500 internal server error message.

Removing the code makes everything return back to normal.


Agus Setiawan comments:

try use this plugin : http://bluedogwebservices.com/wordpress-plugin/authenticate/

2012-05-27

Jatin Soni answers:

add this line at the top of your .htaccess file of your site

AddType x-mapp-php5 .php

for example your .htaccess file should be like below

AddType x-mapp-php5 .php


# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /mysite/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /mysite/index.php [L]
</IfModule>

# END WordPress


ianbong comments:

Adding the code makes the dashboard appear weird.. loss of all appearance with code only.

See the attachment to know what I mean.