Ask your WordPress questions! Pay money and get answers fast! (more info)

Feedo Social Feed Plugin - Twitter Not Working WordPress

  • SOLVED

I'm currently working on a project that will feature a social wall with Facebook, Instagram and Twitter. We decided to use a plugin called Feedo. Here are some links for more information on the plugin:

[[LINK href="http://codecanyon.net/item/feedo-wordpress-social-feed-stream/5967474"]]Code Canyon Page[[/LINK]]
[[LINK href="http://www.alchemythemes.com/wordpress-plugins/feedo-wordpress-social-stream-feed/"]]Developer Page[[/LINK]]
[[LINK href="http://www.alchemythemes.com/wp-content/uploads/2013/11/documentation1.pdf"]]Developer Documentation[[/LINK]]

I followed the instructions provided in the above documentation, but the Twitter portion is returning the following errors:

Warning: array_map() expects parameter 1 to be a valid callback, class 'OAuthUtil' not found in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 762

Warning: array_map() expects parameter 1 to be a valid callback, class 'OAuthUtil' not found in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 762

Warning: array_combine() expects parameter 1 to be array, null given in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 892

Warning: uksort() expects parameter 1 to be array, null given in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 896

Warning: Invalid argument supplied for foreach() in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 899

Warning: array_map() expects parameter 1 to be a valid callback, class 'OAuthUtil' not found in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 762

Warning: implode(): Invalid arguments passed in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 395

Warning: array_map() expects parameter 1 to be a valid callback, class 'OAuthUtil' not found in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 762

Warning: implode(): Invalid arguments passed in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 131

Warning: array_map() expects parameter 1 to be a valid callback, class 'OAuthUtil' not found in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 762

Warning: array_map() expects parameter 1 to be a valid callback, class 'OAuthUtil' not found in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 762

Warning: array_combine() expects parameter 1 to be array, null given in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 892

Warning: uksort() expects parameter 1 to be array, null given in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 896

Warning: Invalid argument supplied for foreach() in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/twitter_widget/twitteroauth/twitteroauth/OAuth.php on line 899

Warning: Invalid argument supplied for foreach() in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/at-social-apis-twitter.php on line 16

Warning: Invalid argument supplied for foreach() in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/at-social-apis-twitter.php on line 21

Warning: Attempt to assign property of non-object in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/at-social-apis-twitter.php on line 80

Warning: Attempt to assign property of non-object in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/at-social-apis-twitter.php on line 82

Warning: Attempt to assign property of non-object in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/at-social-apis-twitter.php on line 86

Warning: Attempt to assign property of non-object in /home/redobru0/public_html/_sites/vida-r2/wp-content/plugins/at-feedo/includes/at-social-apis-twitter.php on line 95


You can view this issue live at:
[[LINK href="http://redone.org/_sites/vida-r2/social-stream/"]]http://redone.org/_sites/vida-r2/social-stream/[[/LINK]]

I've posted the two files that are causing the issue here:
[[LINK href="http://redone.org/_sites/Feedo-Twitter.zip"]]http://redone.org/_sites/Feedo-Twitter.zip[[/LINK]]

I (along with other people who have purchased this plugin) have reached out to the developer, but he has not responded to questions in some time:
[[LINK href="http://alchemy.ticksy.com"]]Feedo Plugin Support Forum[[/LINK]]

Any help would be greatly appreciated.

Answers (2)

2014-02-12

Dbranes answers:

You can first suppress the errors/warnings on your live site with

define('WP_DEBUG', TRUE );
define('WP_DEBUG_LOG', TRUE );
define('WP_DEBUG_DISPLAY', FALSE );
@ini_set('display_errors',0);


in your <em>wp-config.php </em> file, while you fix the plugin.


---

There are only two files in Feedo-Twitter.zip:

<em>at-social-apis-twitter.php</em> and <em>OAuth.php</em>

but these are not general plugin files. How did you activate it?

ahh, ok you just zipped these two problematic files ;-)

---

I wonder if this line:

return array_map(array('OAuthUtil', 'urlencode_rfc3986'), $input);


should be

return array_map('at_feedo_OAuthUtil::urlencode_rfc3986', $input);



Michael Brumm comments:

This is just a test site for now, but thanks for the error suppression tip.


Michael Brumm comments:

Since this is a premium plugin ($14) and provides income to the developer, I can't justify posting the entire plugin here, so I just posted the Twitter files identified in the errors.


Michael Brumm comments:

Dbranes,

That appears to be the ANSWER!!!
Thank you so much!!


Dbranes comments:

ok great ;-)

hopefully the plugin developer will fix this ;-)

2014-02-12

Hariprasad Vijayan answers:

Hello,

Please make sure that you are using proper Twitter details. Check "Callback URL" of your twitter app configuration.


Michael Brumm comments:

I've followed the documentation provided with the plugin and have filled in the following Twitter App details within the Feedo Settings:

• Consumer Key
• Consumer Secret
• Access Token
• Access Token Secret

I'm assuming somethings wrong with the code, as others are having the same issues


Michael Brumm comments:

I entered the Callback URL originally when setting up App, but I see that is now blank... Upon re-entering the "Callback URL" and pressing the "Update settings" button, the Callback URL setting is wiped.

Is it not needed?

Should this field be left blank?
Here's text below the "Callback URL" input field:
Where should we return after successfully authenticating? OAuth 1.0a applications should explicitly specify their oauth_callback URL on the request token step, regardless of the value given here. To restrict your application from using callbacks, leave this field blank.