Ask your WordPress questions! Pay money and get answers fast! Comodo Trusted Site Seal
Official PayPal Seal

Debugging index page WordPress

  • SOLVED

Hi there
After upgrading to WP 3 and inserting a new page to my existing page I get the error that the so called "home" page is always linking to a non existing page.
See this www.helvetic-heli.ch
Have no idea what is going and where the mistakte could be ! Any ideas might be helpful...

Answers (5)

2010-07-22

Rashad Aliyev answers:

Hello,

The theme can use 2 front page first one of them index.php second is home.php

P.S: Be sure you upgraded it truly and make your permalink settings again.

Firstly change your permalink to default and save again make it what you want (custom) then try.


Rashad Aliyev comments:

Did you rebuild your permalink settings?


Frank K comments:

Thanks for the idea with the permalinks. I will try this tonight. In about 4 hours. Right now I only can work on mobile devices. I haven´t heard btw that this theme version wouldn´t work under WP3. It should do so,


Rashad Aliyev comments:

Ok, If you need then feel free contact with me.


Frank K comments:

Ok, I did set the permalinks to default value, but that doesn´t change anything...


Rashad Aliyev comments:

The problem then I think about your plugins. Please check redirections..


Rashad Aliyev comments:

<em><strong>Mission Completed..</strong></em>

2010-07-22

Navjot Singh answers:

Would you please explain clearly what exactly you did where you said inserting a new page to an existing page?


Frank K comments:

I inserted the page you can now find as the error page showing up when you hit the home button. It was the exact path that I wanted for the new page within my site. No somehow this page is always displayed when you hit the home button. Does that make things clearer ?

2010-07-22

Utkarsh Kukreti answers:

What have you set as 'Front page displays' in Settings -> Reading? Is it the correct page you want to show?

Also, do what all plugins do you have activated?


Frank K comments:

Yes, all the plugins run normally and I haven´t found any mistake. Yes, it is the correct page inserted under Setting - Reading ...

2010-07-22

Oleg Butuzov answers:

1) in 3.0 used optimized rewrite urls. so the reson can also be is that url scheme changed.
2) check settings in reading section (page that selected there actualy can be in draft mode)
3) you can specify tempalte for for the home page using template home.php
4) custom solution. just message me [email protected].ua


Oleg Butuzov comments:

hm... there is redirect... witch mean its can be hardcoded in some of the templates, witch also men its "hardcoded"... its not fits by current url structure.


Frank K comments:

Ok. I changed the permalinks to the default value. The rest of the site is working normal, but when I click the home button I still get the wrong page. There must be a hard code somewhere. You have any idea ?


Oleg Butuzov comments:

if you message me ftp and wp details i can help...
[email protected]

2010-07-22

Pippin Williamson answers:

Go to Settings -> Permalinks and click "update permalinks"

That should fix your problem.


Frank K comments:

Try to set it to default. Without any change... Any other idea?