Ask your WordPress questions! Pay money and get answers fast! Comodo Trusted Site Seal
Official PayPal Seal

Autofocus Pro - problem with search WordPress

  • SOLVED

Hi,

I am having an issue with the search function in Autofocus Pro. If you run a search on my site (www.tomeatsjencooks.com) the search function works but the formatting is screwy. The text leaks into each other.

EDIT - I have uploaded an image on my blog to demonstrate this - see here http://www.tomeatsjencooks.com/?p=250

I have also noticed this happens with the demo site of autofocus pro so have a slight concern that it might be an unsolvable problem? Any suggestions are welcome though. Link to the main site is here http://fthrwght.com/autofocus/prodemo/?s=demo

Many thanks

Tom

Answers (4)

2010-09-28

Denzel Chia answers:

Hi,

I had this autofocus pro theme, and had tested my answer in it.

<strong>Do not change anything in your stylesheet. Do not put any codes in your <head> tag. Do it the WordPress way by using a function to hook into <head> tag.</strong>

You need to hook in the css to <head> so as to add on to the css in the stylesheet in order for this to work. You do not need other extra css codes.

Please put the following codes in your functions.php in autofocuspro folder.


function autofocus_ie_css_fix(){
echo"
<!--[if IE]>

<style type=\"text/css\">

#content .entry-meta {
position:absolute !important;
right:0 !important;
}

.single #content .entry-meta {
position:absolute !important;
right:0 !important;
}

#content .page-title {
position:absolute !important;
}

.hentry{
position:relative;
top:180px;
}

</style>

<![endif]-->
";
}
add_action('wp_head','autofocus_ie_css_fix');


<em><strong>Click on compatibility mode in your IE and you will see that it is fixed.
The category does not merge with the content anymore.
The previous and next posts arrows are in position too.</strong></em>


Thanks.


Tom comments:

Hi Denzel - where do I put that in the functions.php file. I just tried to add it at the top of the file and that definitely didn't work.

I am still learning to find my way around this code!


Denzel Chia comments:

Hi,

Add it at the top of functions.php below the <?php

If you cannot figure out, drop me your email, I will send you a zip copy of the functions.php

Thanks.


Denzel Chia comments:

Do not add between //
// means comments.

add below <?php

enter above the following to create space.
// Set Up AutoFocus+ Pro
// - Tell WordPress to run af_setup() when the 'after_setup_theme' hook is run.

Thanks.


Denzel Chia comments:

Hi,

If you had added in properly, you may have accidentally deleted <?php wp_head()?> from your theme header when you are adding in the codes from previous answerer.

Thanks.


Denzel Chia comments:

Hi,

One more thing, please clear your IE cache after adding in the codes in functions.php
So that it will show up correctly.
My internet explorer is version 8

Thanks.


Denzel Chia comments:

Just checked your site. browsed the source.
You need to remove the code added in thematic header.
Remove the codes given by Rashad, and any css you changed in your style.css

Then add my codes in functions.php
Then it will work.

If you need the whole set of theme again. let me know.

Thanks.

2010-09-27

enodekciw answers:

can you show me screenshot with what's wrong on that search page, because it shows up pretty alright for me


Tom comments:

Screenshot attached. If you notice that the text has a bleed into it of other data (see the blue). I think it is the categories, and date information etc.


enodekciw comments:

What browser you're using? Cause it looks perfect for me. Check screenshot.