logo
Ask your WordPress questions! Pay money and get answers fast! (more info)

Warning: Please do not give out any FTP or ssh credentials to anyone, unless you trust them completely. Giving out login details is dangerous.

If the asker does not get an answer then they have 10 days to request a refund.

$10
How to rebuild WordPress permalinks

See this for background info:

http://www.wpquestions.com/question/showLoggedIn/id/7313

So if I now have a few thousand posts (just imported from another blog), and I change the structure of the permalinks, and suddenly all the pages on the site give 404 errors, what is the easiest way to rebuild all the perma-links?

This question has been answered.

Lawrence Krubner | 09/25/12 at 4:29pm Edit


(3) Possible Answers Submitted...

See a chronological view of answers?

Warning: Please do not give out any FTP or ssh credentials to anyone, unless you trust them completely. Giving out login details is dangerous.

  • avatar
    Last edited:
    09/25/12
    4:32pm
    Michael Caputo says:

    Go to Settings > Permalinks, and click save changes.

    Make sure you choose the correct permalink structure.

    Previous versions of this answer: 09/25/12 at 4:32pm

    • 09/25/12 4:43pm

      Lawrence Krubner says:

      I tried that several times, but it does not work.

  • avatar
    Last edited:
    09/25/12
    4:39pm
    LatinUnit says:

    Choose default permalink and save, then choose the new permalink structure, for best seo try /%postname%/ or /%category%/%postname%/ and save again

    Then check the .htacess to see if it is like the following

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    • 09/25/12 4:50pm

      LatinUnit says:

      If you have wordpress SEO, try deactivating it deleting it then reupload it, also flush your browser and the wp cache if any.

      Very often is due to wordpress seo

    • 09/25/12 4:53pm

      LatinUnit says:

      The following usually works also:

      Go to Settings > Permalinks and click "Save Settings"
      Go to SEO > Permalinks and click "Save Settings"

    • 09/25/12 5:17pm

      Lawrence Krubner says:

      Nice call. The .htaccess file was missing. Fixed.

  • avatar
    Last edited:
    09/25/12
    4:48pm
    Abdelhadi Touil says:

    Make your .htaccess writable (chmod to 777) via FTP, and then go to permalink setting and resave it, and test if it's working. If everything is ok rechange .htaccess chmod to 644 again.
    Good luck.

This question has expired.



Lawrence Krubner, Gabriel Reguly, Francisco Javier Carazo Gil, Arnav Joy, Manoj Raj, Martin Pham, Dbranes voted on this question.



Current status of this question: Completed



Warning: Please do not give out any FTP or ssh credentials to anyone, unless you trust them completely. Giving out login details is dangerous.

If the asker does not get an answer then they have 10 days to request a refund.