logo
Ask your WordPress questions! Pay money and get answers fast! (more info)

Warning: Please do not give out any FTP or ssh credentials to anyone, unless you trust them completely. Giving out login details is dangerous.

If the asker does not get an answer then they have 10 days to request a refund.

$30
WP Admin White Screen

I am really unsure of what happened to my blog. I can no longer login to the admin as every time I visit the url ( http://schiphop.com/wp-admin/ ) it is a blank screen. I have also found that if you visit the site without the www prefix it is a blank white screen.

I thought it may have been wp super cache causing the issue so I tried manually deactivating it through the database and also by renaming the plugin directory. No luck...

I have also tried deactivating all of the plugins, but nothing is working.

I know this may be a more involved question, but am desperate for help!

Does anyone know how I can fix this issue and begin blogging on this site again?

This question has been answered.

Auz Clement | 06/01/10 at 12:11am Edit


(6) Possible Answers Submitted...

See a chronological view of answers?

Warning: Please do not give out any FTP or ssh credentials to anyone, unless you trust them completely. Giving out login details is dangerous.

  • avatar
    Last edited:
    06/03/10
    12:13pm
    Andrzej Zglobica says:

    Hey,
    I'll be happy to look into your issue - but I need your FTP data, can you please provide them by private message?
    Thanks

    • 06/01/10 12:39am

      Auz Clement says:

      Unfortunately, the host for this site does not allow FTP, but I have SVN access. I will need to request a temporary username and pass to let you in.

      First let me try some of the other recommendations. Thanks for replying!

  • avatar
    Last edited:
    06/01/10
    12:19am
    Rashad Aliyev says:

    Dear Auz Clement,

    Do you have WP-Cache enabled? Sometimes deleting the files in this folder can help out.. Try checking wp-content/cache .

    If thats not it, you could try deleting the wp-admin folder and re-uploading it, this might work as well!

    Otherwise if you installed new plugin before it, login to your ftp and rename all of plugin names. Not plugin directory.

    best regards,

    • 06/01/10 12:22am

      Rashad Aliyev says:

      Also tell me, did you tried to edit the footer?
      Some are encrypted to protect the designer's copyright and if you did you will need to upload back the theme for your site for the footer part.

      However clear your own browsers cache before checking again or use ( CTRL + F5 ).

    • 06/01/10 12:25am

      Rashad Aliyev says:

      I also find WordPress helps for you.

      That's guarantee of fixing your problem. http://wordpress.org/support/topic/199125

      regards,

    • 06/01/10 1:27am

      Rashad Aliyev says:

      Friend, I gave you solution:

      1) deleting extra spaces in wp-admin/admin-functions.php
      2) deleting spaces in wp-content/themes/[mytheme]/functions.php
      3) deleting spaces enters from top and footers in wp-includes/functions.php, functions.wp-scripts.php, and functions.wp-styles.php
      4) looked for define(WP-CACHE in wp-config, if not found go to next step, if find delete this. )
      5) backed up the whole wp-admin folder (for quick way rename and not delete yet), re-uploaded it.

      Make it! It'll works fine.

      Regards,

    • 06/01/10 1:30am

      Rashad Aliyev says:

      Friend I found something in your host,


      Notice: Undefined index: page_id in /mnt/home/schiphop/public_html/wp-content/plugins/shopp/Shopp.php on line 909

      Notice: Trying to get property of non-object in /mnt/home/schiphop/public_html/wp-content/plugins/shopp/core/model/Cart.php on line 145

      Notice: Trying to get property of non-object in /mnt/home/schiphop/public_html/wp-content/plugins/shopp/core/model/Cart.php on line 145


      Login to your host and rename your Shopp plugin. It's making problem. After that if not solved that make before suggestion for deleting spaces.

  • avatar
    Last edited:
    06/01/10
    12:31am
    Monster Coder says:

    hello,
    nothing more can be told until we see error messages.

    open wp-config.php file and append the following lines:


    error_reporting(E_ALL);
    ini_set('display_error',1);


    then you should see error messages on your site that may help you troubleshooting the issue.

    • 06/01/10 12:34am

      Monster Coder says:

      wp-login.php is coming fine. so problem may be with backend only.

  • avatar
    Last edited:
    06/01/10
    2:28am
    Oleg Butuzov says:

    1)
    put into your wp-config.php
    define('WP_DEBUG', true);

    2)...

    need to debug shopp plugin to resove problem. you can skype me to make it workable. oleg.butuzov

    -----------

    and don't forget a problem plugin has a support
    http://forums.shopplugin.net/forum/help-desk

    Previous versions of this answer: 06/01/10 at 2:18am | 06/01/10 at 2:19am | 06/01/10 at 2:28am

  • avatar
    Last edited:
    06/01/10
    2:04am
    Erez S says:

    Here is what you should do:
    1)Delete all your themes except the default one(this make sure that non of your themes causing the problem)
    2)Delete all of your plugins(this makes sure non of your plugins causing it)
    3)Redonwload the files of wordpress and upload only the wp-admin directory(because sometimes there is a problem with the exctraction or the download so do them both again)
    4)There is a nice post on the wordpress support forum that may help you if nothing solved your problem: http://wordpress.org/support/topic/199125
    5)If this still not working,Then try to reinstall wordpress and if this not working you may have problem with your hosting
    After you find out what is causing the problem,let me know and I'll give you solution

    • 06/01/10 2:06am

      Erez S says:

      BTW here is few articles that will give you more options to fix this:
      http://worth2read.org/blog/2009/08/24/blank-page-for-wp-admin/
      http://forums.digitalpoint.com/showthread.php?t=1075653
      http://silentbits.com/wordpress/blank-page-with-wordpress-howto-fix-that/
      http://www.pleasereboot.com/blank-wp-admin/
      http://blog.swamiwebdesign.com/wordpress/wordpress-wp-adminpostphp-page-goes-blank-when-you-try-to-edit-a-post-and-save-it.html
      Try to do all the solution :)

  • avatar
    Last edited:
    06/01/10
    7:14pm
    DarrenM says:

    In my experience the functions.php can cause problems like this. Try renaming your current theme, then try your admin panel which should load.

This question has expired.





Current status of this question: Completed



Warning: Please do not give out any FTP or ssh credentials to anyone, unless you trust them completely. Giving out login details is dangerous.

If the asker does not get an answer then they have 10 days to request a refund.