Ask your WordPress questions! Pay money and get answers fast! (more info)

Contact Form 7 working and not working

Hello!

First time posting a questions. I read several posts before deciding to ask. Anyway...

I created a site for my company, signed up for a new hosting and everything. But before launching it, i created a test site using my personal account

bottom line, contact form 7 works wonderfully in the test site, but in my new site, using basically the same settings in the contact form (except for the file number, to upload files and the email addresses of course) is not working, it says that it sends the emails but i dont receive them.

any idea of what the issue could be?

regards

Answers (3)

2015-06-09

Darlene Grace Arcenal answers:

Have you change the sender of the email? It should be [email protected] or [email protected]


jbali85 comments:

HI Darlene, on the site that works just fine, i never made any modifications. on the one that doesn't, i just tried that... unsuccesfully... i changed it from [email protected] to [email protected] and nothing yet.

also i tried with two diferent To email addresses, one was my work email and with my personal hotmail.com email as well... nothing.


Darlene Grace Arcenal comments:

Please make sure that [email protected] is the new site and not the devsite.


jbali85 comments:

Yes, that is right. I only changed the first part. it still has the .com part of the actual live company site.


Darlene Grace Arcenal comments:

Have you asked your hosting company about it? Because when I had a problem like that with contact form 7, I contacted our hosting company.


jbali85 comments:

I guess that is my next step...


jbali85 comments:

I asked my hosting company, they say since it is a wp plugin they are unable to help me...


jbali85 comments:

i found a difference!. In the site that is working, i have contact form version 4.1.2 and on the one that is not working i have version 4.2 ... that might be it.

2015-06-10

Bob answers:

To check mailing is working fine.

logout from admin if you are logged in.

click forget password link and enter you email.

let us know if you get any error or get an email in your inbox?


Bob comments:

You should also check that if it works with smtp plugin or not.


Bob comments:

Can you provide us url of the page?
which host are you using? Is it window or linux?
have you tried smtp plugin?


jbali85 comments:

Thank you.. sorry i didnt reply earlier. It actually works now... long story short, the url had been marked as spam by an outgoing spam filter from the hosting provider... really odd since we do not submit newsletter or any bulk mail.

any way, it has been fixed.

thank you all for your support.

2015-06-10

Arnav Joy answers:

did you check your spam folder?


jbali85 comments:

Yep. I did