Ask your WordPress questions! Pay money and get answers fast! (more info)

Broken Image Slider

  • SOLVED

The homepage image slider for the site http://georgiapecan.com appears to be broken. 3 images should rotate through, but only one displays. On the WP dashboard, the "Widgets" tab has disappeared under the "Appearance" menu. I'm not sure if it's an update or plugin conflict that has caused this. Deactivating and reactivating the plugins caused the header and navigation to disappear and I had to restore from backup, and it did not fix the slider. Any insight into which areas I might look into to fix this problem would be greatly appreciated. I am not a developer and did not build the site, but now I manage it for a client.

Answers (2)

2014-04-16

Sébastien | French WordpressDesigner answers:

you need add a title attribute on each image
like that
<img src="http://georgiapecan.com/wp-content/uploads/2011/07/slider-certification-1024x385.jpg" title="the title of my img">


Anne Shenton comments:

Where would I add this?


Sébastien | French WordpressDesigner comments:

open this file :
http://georgiapecan.com/wp-content/plugins/easy-nivo-slider/3rd-party/jquery.nivo.slider.js

replace this line :
if(title.substr(0,1) == '#') title = $(title).html();
by this line
if(title.substr(0,1) == '#') title = title.html();


Anne Shenton comments:

I tried this, and do not see any change.


Sébastien | French WordpressDesigner comments:

in this case, could you only just change this line
if(vars.currentImage.attr('title') != ''){
by this line
if(vars.currentImage.attr('title')){


Anne Shenton comments:

Sorry, I see no change with this either.


Sébastien | French WordpressDesigner comments:

clear your cache and see that the problem is resolved :)
I see your slider works on my screen :)


Anne Shenton comments:

That worked! Thanks!!!

2014-04-16

Kyle answers:

You are getting an error from the Nivo Slider script, that is causing the script to not load completely.

Do you have the most recent version installed?


Anne Shenton comments:

Yes I do, and I also just updated NextGen gallery and that did not seem to fix it either.


Kyle comments:

The error is coming as part of the script that creates the captions for the images, can you try altering your image titles and captions to see if that alters the error?